VueJS / VueCLI + ESLint - The template root requires exactly one element.

  • Hey,


    Folgender Fehler: ESLint: The template root requires exactly one element. (vue/valid-template-root)


    ich habe folgenes Format:


    HTML
    1. <template>
    2. <div></div>
    3. <div></div>
    4. <div></div>
    5. </template>


    Ich kenne bereits die Wiki Seite / den Eintrag dazu (-> https://github.com/vuejs/eslin…es/valid-template-root.md).

    Problem ist, wenn ich jetzt ein div drum wrappen würde:


    Code
    1. <template>
    2. <div>
    3. <div></div>
    4. <div></div>
    5. <div></div>
    6. </div>
    7. </template>


    Würde das CSS nicht mehr so funktionieren wie es sollte. Nur leider fällt mir da keine Lösung zu ein. Bleibt mir keine andere Wahl als das CSS umzuschreiben?