Nullpointer bei Config

  • Guten Abend,

    Ich hab jetzt schon viel rum probiert aber es will einfach nicht.. ich seh den Fehler auch nicht die Console gibt den Fehler in meiner SaveLocation Methode Zeile 27 aus aber ich wüsste nicht an was das liegen kann? Wenn ich den Server neustarte erscheint auch kein Ordner mit einer Config Datei im Plugins Ordner... danke für jede Hilfe!





    Meine Config Klasse:

    https://pastebin.com/j1vP0TEa


    Main Klasse

    https://pastebin.com/hPsy3Sxc


    Und hier nochmal die Command Klasse in der ich die Config erstelle

    https://pastebin.com/59k7XZtK


    Hier der Fehler in der Console:

    [17:35:36] [Server thread/INFO]: HabdxchLieb issued server command: /setup Lobby

    [17:35:36] [Server thread/ERROR]: null

    org.bukkit.command.CommandException: Unhandled exception executing command 'setup' in plugin SkyEvent_InvasionRS v1.0

    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:47) ~[spigot.jar:2991-Spigot-018b9a0-f3f3094]

    at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:149) ~[spigot.jar:2991-Spigot-018b9a0-f3f3094]

    at org.bukkit.craftbukkit.v1_16_R3.CraftServer.dispatchCommand(CraftServer.java:763) ~[spigot.jar:2991-Spigot-018b9a0-f3f3094]

    at net.minecraft.server.v1_16_R3.PlayerConnection.handleCommand(PlayerConnection.java:1788) ~[spigot.jar:2991-Spigot-018b9a0-f3f3094]

    at net.minecraft.server.v1_16_R3.PlayerConnection.c(PlayerConnection.java:1631) ~[spigot.jar:2991-Spigot-018b9a0-f3f3094]

    at net.minecraft.server.v1_16_R3.PlayerConnection.a(PlayerConnection.java:1584) ~[spigot.jar:2991-Spigot-018b9a0-f3f3094]

    at net.minecraft.server.v1_16_R3.PacketPlayInChat.a(PacketPlayInChat.java:47) ~[spigot.jar:2991-Spigot-018b9a0-f3f3094]

    at net.minecraft.server.v1_16_R3.PacketPlayInChat.a(PacketPlayInChat.java:1) ~[spigot.jar:2991-Spigot-018b9a0-f3f3094]

    at net.minecraft.server.v1_16_R3.PlayerConnectionUtils.lambda$0(PlayerConnectionUtils.java:19) ~[spigot.jar:2991-Spigot-018b9a0-f3f3094]

    at net.minecraft.server.v1_16_R3.TickTask.run(SourceFile:18) ~[spigot.jar:2991-Spigot-018b9a0-f3f3094]

    at net.minecraft.server.v1_16_R3.IAsyncTaskHandler.executeTask(SourceFile:144) ~[spigot.jar:2991-Spigot-018b9a0-f3f3094]

    at net.minecraft.server.v1_16_R3.IAsyncTaskHandlerReentrant.executeTask(SourceFile:23) ~[spigot.jar:2991-Spigot-018b9a0-f3f3094]

    at net.minecraft.server.v1_16_R3.IAsyncTaskHandler.executeNext(SourceFile:118) ~[spigot.jar:2991-Spigot-018b9a0-f3f3094]

    at net.minecraft.server.v1_16_R3.MinecraftServer.bb(MinecraftServer.java:942) ~[spigot.jar:2991-Spigot-018b9a0-f3f3094]

    at net.minecraft.server.v1_16_R3.MinecraftServer.executeNext(MinecraftServer.java:935) ~[spigot.jar:2991-Spigot-018b9a0-f3f3094]

    at net.minecraft.server.v1_16_R3.IAsyncTaskHandler.awaitTasks(SourceFile:127) ~[spigot.jar:2991-Spigot-018b9a0-f3f3094]

    at net.minecraft.server.v1_16_R3.MinecraftServer.sleepForTick(MinecraftServer.java:919) ~[spigot.jar:2991-Spigot-018b9a0-f3f3094]

    at net.minecraft.server.v1_16_R3.MinecraftServer.w(MinecraftServer.java:851) ~[spigot.jar:2991-Spigot-018b9a0-f3f3094]

    at net.minecraft.server.v1_16_R3.MinecraftServer.lambda$0(MinecraftServer.java:164) ~[spigot.jar:2991-Spigot-018b9a0-f3f3094]

    at java.lang.Thread.run(Thread.java:834) [?:?]

    Caused by: java.lang.NullPointerException

    at de.habdxchlieb.utils.ConfigLocationUtil.saveLocation(ConfigLocationUtil.java:27) ~[?:?]

    at de.habdxchlieb.commands.CMD_Setup.onCommand(CMD_Setup.java:31) ~[?:?]

    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:45) ~[spigot.jar:2991-Spigot-018b9a0-f3f3094]

    ... 19 more



    Würde mich sehr freuen wenn mir da jemand hilft!

    LG. Thomas

  • private SkyEvent_Raumschiff plugin; in CMD_Setup wird nie initialisiert, ist also null.

    MfG


    00110101 00110001 00110101 00111000 00110100 00110110 00110011 00110001 00110101 00111001 00110101 00110111 00110100 00110110 00110011 00110000 00110110 00110001 00110101 00110111 00110100 01000100 00110011 01000100 8o

  • private SkyEvent_Raumschiff plugin; in CMD_Setup wird nie initialisiert, ist also null.

    Aber wie soll ich das Initialisieren? Stehe gerade iwi aufm schlauch


    Okay habs jetzt selber gefunden .-. Danke dir haha :)

    Einmal editiert, zuletzt von HabdxchLieb () aus folgendem Grund: Ein Beitrag von HabdxchLieb mit diesem Beitrag zusammengefügt.